What’s Vulnerable › Vulnerabilities
CVE-2025-62220: Windows Subsystem for Linux GUI Remote Code Execution Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-11 · updated 2026-10-18
- Weakness: CWE-122
Description
Heap-based buffer overflow in Windows Subsystem for Linux GUI allows an unauthorized attacker to execute code over a network.
Affected products
- Microsoft Windows Subsystem for Linux (WSL2): before 2.6.2 — fixed in 2.6.2
- Microsoft Windows Subsystem for Linux (WSL2): from 1.0.0 before 2.6.2 — fixed in 2.6.2
How to fix
Upgrade to a fixed version: Microsoft Windows Subsystem for Linux (WSL2) 2.6.2; Microsoft Windows Subsystem for Linux (WSL2) 2.6.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-62220 or the next vulnerability affects your stack