What’s Vulnerable › Vulnerabilities
CVE-2025-62231: Xorg: xmayland: value overflow in xkbsetcompatmap()
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-30 · updated 2026-07-01
- Weakness: CWE-190
Description
A flaw was identified in the X.Org X server’s X Keyboard (Xkb) extension where improper bounds checking in the XkbSetCompatMap() function can cause an unsigned short overflow. If an attacker sends specially crafted input data, the value calculation may overflow, leading to memory corruption or a crash.
Affected products
- Debian Linux: 11.0
- IBM AIX: from 7.2.5 before 7.2.5.12; from 7.3.2 before 7.3.3.3; 7.3.4 — fixed in 7.2.5.12, 7.3.3.3
- IBM VIOS: from 4.1.0 before 4.1.1.30; 4.1.2.0 — fixed in 4.1.1.30
- Red Hat Enterprise Linux: 8.0, 9.0, 10.0
- RedHat Enterprise Linux Aus: 8.2, 8.4, 8.6
- RedHat Enterprise Linux Els: 6.0, 7.0
- RedHat Enterprise Linux Eus: 8.4, 9.4
- RedHat Enterprise Linux Tus: 8.6, 8.8
- RedHat Enterprise Linux Update Services For Sap Solutions: 8.6, 8.8, 9.0, 9.2
- xorg-x11-server: before 21.1.19 — fixed in 21.1.19
- X.Org xwayland: before 24.1.9 — fixed in 24.1.9
How to fix
Upgrade to a fixed version: IBM AIX 7.2.5.12, 7.3.3.3; IBM VIOS 4.1.1.30; xorg-x11-server 21.1.19; X.Org xwayland 24.1.9. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2025:19432
- https://access.redhat.com/errata/RHSA-2025:19433
- https://access.redhat.com/errata/RHSA-2025:19434
- https://access.redhat.com/errata/RHSA-2025:19435
- https://access.redhat.com/errata/RHSA-2025:19489
- https://access.redhat.com/errata/RHSA-2025:19623
- https://access.redhat.com/errata/RHSA-2025:19909
- https://access.redhat.com/errata/RHSA-2025:20958
- https://access.redhat.com/errata/RHSA-2025:20960
- https://access.redhat.com/errata/RHSA-2025:20961
- https://access.redhat.com/errata/RHSA-2025:21035
- https://access.redhat.com/errata/RHSA-2025:22040
Get alerted when CVE-2025-62231 or the next vulnerability affects your stack