What’s Vulnerable › Vulnerabilities
CVE-2025-62232: Apache APISIX: basic-auth logs plaintext credentials at info level
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-31 · updated 2026-10-07
- Weakness: CWE-532
Description
Sensitive data exposure via logging in basic-auth leads to plaintext usernames and passwords written to error logs and forwarded to log sinks when log level is INFO/DEBUG. This creates a high risk of credential compromise through log access. It has been fixed in the following commit: https://github.com/apache/apisix/pull/12629 Users are recommended to upgrade to version 3.14, which fixes this issue.
Affected products
- Apache Software Foundation Apache APISIX: from 1.0 before 3.14.0 — fixed in 3.14.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache APISIX 3.14.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/32hdgh570btfhg02hfc7p7ckf9v83259
- http://www.openwall.com/lists/oss-security/2025/10/30/4
Get alerted when CVE-2025-62232 or the next vulnerability affects your stack