What’s Vulnerable › Vulnerabilities
CVE-2025-62235: Apache Mynewt NimBLE: Incorrect handling of SMP Security Request could lead to undesirable pairing
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-10 · updated 2026-06-17
- Weakness: CWE-290
Description
Authentication Bypass by Spoofing vulnerability in Apache NimBLE. Receiving specially crafted Security Request could lead to removal of original bond and re-bond with impostor. This issue affects Apache NimBLE: through 1.8.0. Users are recommended to upgrade to version 1.9.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache NimBLE: before 1.9.0 — fixed in 1.9.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache NimBLE 1.9.0. Check the vendor advisory for mitigations.
References
- https://github.com/apache/mynewt-nimble/commit/41f67e391e788c5feef9030026cc5cbc5431838a
- https://lists.apache.org/thread/rw2mrpfwb9d9wmq4h4b6ctcd6gpkk2ho
- http://www.openwall.com/lists/oss-security/2026/01/08/4
Get alerted when CVE-2025-62235 or the next vulnerability affects your stack