What’s Vulnerable › Vulnerabilities

CVE-2025-62256

Description

Liferay Portal 7.4.0 through 7.4.3.109, and Liferay DXP 2023.Q4.0 through 2023.Q4.5, 2023.Q3.1 through 2023.Q3.7, 7.4 GA through update 92, 7.3 GA through update 35, and older unsupported versions does not properly restrict access to OpenAPI in certain circumstances, which allows remote attackers to access the OpenAPI YAML file via a crafted URL.

Affected products

How to fix

Upgrade to a fixed version: Liferay Portal 7.4.3.110. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-62256 or the next vulnerability affects your stack