What’s Vulnerable › Vulnerabilities

CVE-2025-6227: Invite token is used as part of the secure communication

Description

Mattermost versions 10.5.x <= 10.5.7, 9.11.x <= 9.11.16 fail to negotiate a new token when accepting the invite which allows a user that intercepts both invite and password to send synchronization payloads to the server that originally created the invite via the REST API.

Affected products

How to fix

Upgrade to a fixed version: Mattermost 10.5.8, 9.11.17. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-6227 or the next vulnerability affects your stack