What’s Vulnerable › Vulnerabilities
CVE-2025-62291
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-16 · updated 2026-06-17
- Weakness: CWE-191
Description
In the eap-mschapv2 plugin (client-side) in strongSwan before 6.0.3, a malicious EAP-MSCHAPv2 server can send a crafted message of size 6 through 8, and cause an integer underflow that potentially results in a heap-based buffer overflow.
Affected products
- strongSwan: from 4.2.12 before 6.0.3 — fixed in 6.0.3
How to fix
Upgrade to a fixed version: strongSwan 6.0.3. Check the vendor advisory for mitigations.
References
- https://github.com/strongswan/strongswan/commits/master/src/libcharon/plugins/eap_mschapv2
- https://github.com/strongswan/strongswan/releases
- https://www.strongswan.org/blog/2025/10/27/strongswan-vulnerability-%28cve-2025-62291%29.html
- https://lists.debian.org/debian-lts-announce/2025/11/msg00002.html
Get alerted when CVE-2025-62291 or the next vulnerability affects your stack