What’s Vulnerable › Vulnerabilities
CVE-2025-62292
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-10 · updated 2026-10-08
- Weakness: CWE-669
Description
In SonarQube before 25.6, 2025.3 Commercial, and 2025.1.3 LTA, authenticated low-privileged users can query the /api/v2/users-management/users endpoint and obtain user fields intended for administrators only, including the email addresses of other accounts.
Affected products
- SonarSource SonarQube: from 10.2 Community before 25.6 Community; from 10.2 Commercial before 2025.3 Commercial; from 2025.1 LTA before 2025.1.3 LTA — fixed in 2025.1.3 LTA, 2025.3 Commercial, 25.6 Community
How to fix
Upgrade to a fixed version: SonarSource SonarQube 2025.1.3 LTA, 2025.3 Commercial, 25.6 Community. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-62292 or the next vulnerability affects your stack