What’s Vulnerable › Vulnerabilities
CVE-2025-62327: HCL DevOps Deploy is susceptible to insufficiently protected credentials
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-07 · updated 2026-10-07
- Weakness: CWE-522
Description
In HCL DevOps Deploy 8.1.2.0 through 8.1.2.3, a user with LLM configuration privileges may be able to recover a credential previously saved for performing authenticated LLM Queries.
Affected products
- HCLSoftware HCL DevOps Deploy: from 8.1.2.0 before 8.1.2.3 — fixed in 8.1.2.3
How to fix
Upgrade to a fixed version: HCLSoftware HCL DevOps Deploy 8.1.2.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-62327 or the next vulnerability affects your stack