What’s Vulnerable › Vulnerabilities
CVE-2025-6234: Hostel < 1.1.5.8 - Reflected XSS
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-07-10 · updated 2026-06-17
- Weakness: CWE-79
Description
The Hostel WordPress plugin before 1.1.5.8 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin.
Affected products
- Bob Hostel: before 1.1.5.8 — fixed in 1.1.5.8
How to fix
Upgrade to a fixed version: Bob Hostel 1.1.5.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/7447c4e1-81b9-4415-b425-27491ff692b2/
- https://wpscan.com/vulnerability/7447c4e1-81b9-4415-b425-27491ff692b2/
Get alerted when CVE-2025-6234 or the next vulnerability affects your stack