What’s Vulnerable › Vulnerabilities
CVE-2025-62354
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-26 · updated 2026-10-18
- Weakness: CWE-78
Description
Improper neutralization of special elements used in an OS command ('command injection') in Cursor allows an unauthorized attacker to execute commands that are outside of those specified in the allowlist, resulting in arbitrary code execution.
Affected products
- cursor: from 1.3.4 before 2.0 — fixed in 2.0
How to fix
Upgrade to a fixed version: cursor 2.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-62354 or the next vulnerability affects your stack