What’s Vulnerable › Vulnerabilities
CVE-2025-62365: LibreNMS vulnerable to Reflected-XSS in `report_this` function
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-10-13 · updated 2026-10-19
- Weakness: CWE-79
Description
LibreNMS is an open-source, PHP/MySQL/SNMP-based network monitoring system. Prior to 25.7.0, there is a reflected-XSS in `report_this` function in `librenms/includes/functions.php`. The `report_this` function had improper filtering (`htmlentities` function was incorrectly use in a href environment), which caused the `project_issues` parameter to trigger an XSS vulnerability. This vulnerability is fixed in 25.7.0.
Affected products
- librenms: before 25.7.0 — fixed in 25.7.0
How to fix
Upgrade to a fixed version: librenms 25.7.0. Check the vendor advisory for mitigations.
References
- https://github.com/librenms/librenms/commit/30d3dd7e5f5e22a8c23c9db3ad90a731c005b008
- https://github.com/librenms/librenms/security/advisories/GHSA-86rg-8hc8-v82p
Get alerted when CVE-2025-62365 or the next vulnerability affects your stack