What’s Vulnerable › Vulnerabilities
CVE-2025-62372: vLLM vulnerable to DoS with incorrect shape of multimodal embedding inputs
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-21 · updated 2026-10-19
- Weakness: CWE-129
Description
vLLM is an inference and serving engine for large language models (LLMs). From version 0.5.5 to before 0.11.1, users can crash the vLLM engine serving multimodal models by passing multimodal embedding inputs with correct ndim but incorrect shape (e.g. hidden dimension is wrong), regardless of whether the model is intended to support such inputs (as defined in the Supported Models page). This issue has been patched in version 0.11.1.
Affected products
- vllm-project vllm: from 0.5.5 before 0.11.1; 0.11.1-rc0, 0.11.1-rc1 — fixed in 0.11.1
How to fix
Upgrade to a fixed version: vllm-project vllm 0.11.1. Check the vendor advisory for mitigations.
References
- https://github.com/vllm-project/vllm/commit/58fab50d82838d5014f4a14d991fdb9352c9c84b
- https://github.com/vllm-project/vllm/pull/27204
- https://github.com/vllm-project/vllm/pull/6613
- https://github.com/vllm-project/vllm/security/advisories/GHSA-pmqf-x6x8-p7qw
Get alerted when CVE-2025-62372 or the next vulnerability affects your stack