What’s Vulnerable › Vulnerabilities
CVE-2025-62393: Moodle: course access permissions not properly checked in course_output_fragment_course_overview
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-23 · updated 2026-06-17
- Weakness: CWE-284
Description
A flaw was found in the course overview output function where user access permissions were not fully enforced. This could allow unauthorized users to view information about courses they should not have access to, potentially exposing limited course details.
Affected products
- Moodle: from 5.0.0 before 5.0.3 — fixed in 5.0.3
How to fix
Upgrade to a fixed version: Moodle 5.0.3. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/CVE-2025-62393
- https://bugzilla.redhat.com/show_bug.cgi?id=2404426
- https://moodle.org/mod/forum/discuss.php?d=470381
Get alerted when CVE-2025-62393 or the next vulnerability affects your stack