What’s Vulnerable › Vulnerabilities
CVE-2025-62396: Moodle: router (r.php) could expose application directories
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-23 · updated 2026-10-27
- Weakness: CWE-548
Description
An error-handling issue in the Moodle router (r.php) could cause the application to display internal directory listings when specific HTTP headers were not properly configured.
Affected products
- Moodle: from 4.5.0 before 4.5.7; from 5.0.0 before 5.0.3 — fixed in 4.5.7, 5.0.3
How to fix
Upgrade to a fixed version: Moodle 4.5.7, 5.0.3. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/CVE-2025-62396
- https://bugzilla.redhat.com/show_bug.cgi?id=2404429
Get alerted when CVE-2025-62396 or the next vulnerability affects your stack