What’s Vulnerable › Vulnerabilities
CVE-2025-62397: Moodle: router produces json instead of 404 error for invalid course id
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-23 · updated 2026-06-17
- Weakness: CWE-209
Description
The router’s inconsistent response to invalid course IDs allowed attackers to infer which course IDs exist, potentially aiding reconnaissance.
Affected products
- Moodle: from 5.0.0 before 5.0.3 — fixed in 5.0.3
How to fix
Upgrade to a fixed version: Moodle 5.0.3. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/CVE-2025-62397
- https://bugzilla.redhat.com/show_bug.cgi?id=2404430
Get alerted when CVE-2025-62397 or the next vulnerability affects your stack