What’s Vulnerable › Vulnerabilities
CVE-2025-62399: Moodle: password brute force risk when mobile/web services enabled
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-23 · updated 2026-06-17
- Weakness: CWE-307
Description
Moodle’s mobile and web service authentication endpoints did not sufficiently restrict repeated password attempts, making them susceptible to brute-force attacks.
Affected products
- Moodle: from 4.1.0 before 4.1.21; from 4.4.0 before 4.4.11; from 4.5.0 before 4.5.7; from 5.0.0 before 5.0.3 — fixed in 4.1.21, 4.4.11, 4.5.7, 5.0.3
How to fix
Upgrade to a fixed version: Moodle 4.1.21, 4.4.11, 4.5.7, 5.0.3. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/CVE-2025-62399
- https://bugzilla.redhat.com/show_bug.cgi?id=2404432
Get alerted when CVE-2025-62399 or the next vulnerability affects your stack