What’s Vulnerable › Vulnerabilities
CVE-2025-62402: Apache Airflow: Airflow 3 API: /api/v2/dagReports executes DAG Python in API
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-30 · updated 2026-10-08
- Weakness: CWE-250
Description
API users via `/api/v2/dagReports` could perform Dag code execution in the context of the api-server if the api-server was deployed in the environment where Dag files were available.
Affected products
- Apache Airflow: from 3.0.0 before 3.1.1 — fixed in 3.1.1
How to fix
Upgrade to a fixed version: Apache Airflow 3.1.1. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/vbzxnxn031wb998hsd7vqnvh4z8nx6rs
- http://www.openwall.com/lists/oss-security/2025/10/29/7
Get alerted when CVE-2025-62402 or the next vulnerability affects your stack