What’s Vulnerable › Vulnerabilities
CVE-2025-62408: c-ares has a Use After Free vulnerability when connection is cleaned up after error
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-08 · updated 2026-10-14
- Weakness: CWE-416
Description
c-ares is an asynchronous resolver library. Versions 1.32.3 through 1.34.5 terminate a query after maximum attempts when using read_answer() and process_answer(), which can cause a Denial of Service. This issue is fixed in version 1.34.6.
Affected products
- c-ares: from 1.32.3 before 1.34.6 — fixed in 1.34.6
How to fix
Upgrade to a fixed version: c-ares 1.34.6. Check the vendor advisory for mitigations.
References
- https://github.com/c-ares/c-ares/commit/714bf5675c541bd1e668a8db8e67ce012651e618
- https://github.com/c-ares/c-ares/security/advisories/GHSA-jq53-42q6-pqr5
Get alerted when CVE-2025-62408 or the next vulnerability affects your stack