What’s Vulnerable › Vulnerabilities
CVE-2025-62411: Stored XSS in Alert Transport name field in LibreNMS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 12.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-10-16 · updated 2026-10-19
- Weakness: CWE-79
Description
LibreNMS is a community-based GPL-licensed network monitoring system. LibreNMS <= 25.8.0 contains a Stored Cross-Site Scripting (XSS) vulnerability in the Alert Transports management functionality. When an administrator creates a new Alert Transport, the value of the Transport name field is stored and later rendered in the Transports column of the Alert Rules page without proper input validation or output encoding. This leads to arbitrary JavaScript execution in the admin’s browser. This vulnerability is fixed in 25.10.0.
Affected products
- librenms: before 25.10.0 — fixed in 25.10.0
How to fix
Upgrade to a fixed version: librenms 25.10.0. Check the vendor advisory for mitigations.
References
- https://github.com/librenms/librenms/commit/706a77085f4d5964f7de9444208ef707e1f79450
- https://github.com/librenms/librenms/security/advisories/GHSA-frc6-pwgr-c28w
- https://github.com/librenms/librenms/security/advisories/GHSA-frc6-pwgr-c28w
Get alerted when CVE-2025-62411 or the next vulnerability affects your stack