What’s Vulnerable › Vulnerabilities
CVE-2025-62412: LibreNMS alert-rules Cross-Site Scripting Vulnerability
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-10-16 · updated 2026-10-19
- Weakness: CWE-79
Description
LibreNMS is a community-based GPL-licensed network monitoring system. The alert rule name in the Alerts > Alert Rules page is not properly sanitized, and can be used to inject HTML code. This vulnerability is fixed in 25.10.0.
Affected products
- librenms: from 25.8.0 before 25.10.0 — fixed in 25.10.0
How to fix
Upgrade to a fixed version: librenms 25.10.0. Check the vendor advisory for mitigations.
References
- https://github.com/librenms/librenms/commit/dccdf6769976a974d70f06a7ce8d5a846b29db6f
- https://github.com/librenms/librenms/security/advisories/GHSA-6g2v-66ch-6xmh
- https://github.com/librenms/librenms/security/advisories/GHSA-6g2v-66ch-6xmh
Get alerted when CVE-2025-62412 or the next vulnerability affects your stack