What’s Vulnerable › Vulnerabilities
CVE-2025-62422: DataEase SQL injection vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-10-17 · updated 2026-10-19
- Weakness: CWE-89
Description
DataEase is an open source data visualization and analytics platform. In versions 2.10.13 and earlier, the /de2api/datasetData/tableField interface is vulnerable to SQL injection. An attacker can construct a malicious tableName parameter to execute arbitrary SQL commands. This issue is fixed in version 2.10.14. No known workarounds exist.
Affected products
- dataease: before 2.10.14 — fixed in 2.10.14
How to fix
Upgrade to a fixed version: dataease 2.10.14. Check the vendor advisory for mitigations.
References
- https://github.com/dataease/dataease/commit/3c52cc26c4cca1000294346cf99a84b25d38bfb2
- https://github.com/dataease/dataease/security/advisories/GHSA-54m5-xrw4-mv36
Get alerted when CVE-2025-62422 or the next vulnerability affects your stack