What’s Vulnerable › Vulnerabilities
CVE-2025-62429: ClipBucket v5 executes arbitrary PHP code
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-10-20 · updated 2026-10-08
- Weakness: CWE-94
Description
ClipBucket v5 is an open source video sharing platform. Prior to version 5.5.2 #147, ClipBucket v5 is vulnerable to arbitrary PHP code execution. In /upload/admin_area/actions/update_launch.php, the "type" parameter from a POST request is embedded into PHP tags and executed. Proper sanitization is not performed, and by injecting malicious code an attacker can execute arbitrary PHP code. This allows an attacker to achieve RCE. This issue has been resolved in version 5.5.2 #147.
Affected products
- MacWarrior clipbucket-v5: from 5.3 before 5.5.2-147 — fixed in 5.5.2-147
How to fix
Upgrade to a fixed version: MacWarrior clipbucket-v5 5.5.2-147. Check the vendor advisory for mitigations.
References
- https://github.com/MacWarrior/clipbucket-v5/commit/e81bac602c871bb1ad971884003a3a496a2ab50b
- https://github.com/MacWarrior/clipbucket-v5/releases/tag/5.5.2-%23147
- https://github.com/MacWarrior/clipbucket-v5/security/advisories/GHSA-3x4g-x3gv-rjmq
- https://github.com/MacWarrior/clipbucket-v5/security/advisories/GHSA-3x4g-x3gv-rjmq
Get alerted when CVE-2025-62429 or the next vulnerability affects your stack