What’s Vulnerable › Vulnerabilities
CVE-2025-62503: Apache Airflow: Privilege boundary bypass in bulk APIs (create action can upsert existing Pools/Connections/Variables)
- Severity: medium (CVSS 4.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-30 · updated 2026-10-08
- Weakness: CWE-250
Description
User with CREATE and no UPDATE privilege for Pools, Connections, Variables could update existing records via bulk create API with overwrite action.
Affected products
- Apache Airflow: from 3.0.0 before 3.1.1 — fixed in 3.1.1
How to fix
Upgrade to a fixed version: Apache Airflow 3.1.1. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/3v58249qscyn1hg240gh8hqg9pb4okcr
- http://www.openwall.com/lists/oss-security/2025/10/29/8
Get alerted when CVE-2025-62503 or the next vulnerability affects your stack