What’s Vulnerable › Vulnerabilities
CVE-2025-62504: Envoy Lua filter use-after-free when oversized rewritten response body causes crash
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-16 · updated 2026-10-09
- Weakness: CWE-416
Description
Envoy is an open source edge and service proxy. Envoy versions earlier than 1.36.2, 1.35.6, 1.34.10, and 1.33.12 contain a use-after-free vulnerability in the Lua filter. When a Lua script executing in the response phase rewrites a response body so that its size exceeds the configured per_connection_buffer_limit_bytes (default 1MB), Envoy generates a local reply whose headers override the original response headers, leaving dangling references and causing a crash. This results in denial of service. Updating to versions 1.36.2, 1.35.6, 1.34.10, or 1.33.12 fixes the issue. Increasing per_connection_buffer_limit_bytes (and for HTTP/2 the initial_stream_window_size) or increasing per_request_buffer_limit_bytes / request_body_buffer_limit can reduce the likelihood of triggering the condition but does not correct the underlying memory safety flaw.
Affected products
- envoyproxy envoy: before 1.33.12; from 1.34.0 before 1.34.10; from 1.35.0 before 1.35.6; from 1.36.0 before 1.36.2 — fixed in 1.33.12, 1.34.10, 1.35.6, 1.36.2
How to fix
Upgrade to a fixed version: envoyproxy envoy 1.33.12, 1.34.10, 1.35.6, 1.36.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-62504 or the next vulnerability affects your stack