What’s Vulnerable › Vulnerabilities
CVE-2025-6252: Qi Addons For Elementor <= 1.9.1 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-28 · updated 2026-06-17
- Weakness: CWE-79
Description
The Qi Addons For Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via several parameters in all versions up to, and including, 1.9.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- qodeinteractive Qi Addons For Elementor: before 1.9.2 — fixed in 1.9.2
How to fix
Upgrade to a fixed version: qodeinteractive Qi Addons For Elementor 1.9.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/qi-addons-for-elementor/trunk/assets/js/main.js
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=3318746%40qi-addons-for-elementor%2Ftrunk&old=3308494%40qi-addons-for-elementor%2Ftrunk&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/0ef82a52-0a32-4dc4-b027-3d2098549404?source=cve
Get alerted when CVE-2025-6252 or the next vulnerability affects your stack