What’s Vulnerable › Vulnerabilities
CVE-2025-62521: ChurchCRM has unauthenticated RCE in its Install Wizard
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-12-17 · updated 2026-06-17
- Weakness: CWE-94
Description
ChurchCRM is an open-source church management system. Prior to version 5.21.0, a pre-authentication remote code execution vulnerability in ChurchCRM's setup wizard allows unauthenticated attackers to inject arbitrary PHP code during the initial installation process, leading to complete server compromise. The vulnerability exists in `setup/routes/setup.php` where user input from the setup form is directly concatenated into a PHP configuration template without any validation or sanitization. Any parameter in the setup form can be used to inject PHP code that gets written to `Include/Config.php`, which is then executed on every page load. This is more severe than typical authenticated RCE vulnerabilities because it requires no credentials and affects the installation process that administrators must complete. Version 5.21.0 patches the issue.
Affected products
- ChurchCRM CRM: before 5.21.0 — fixed in 5.21.0
How to fix
Upgrade to a fixed version: ChurchCRM CRM 5.21.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-62521 or the next vulnerability affects your stack