What’s Vulnerable › Vulnerabilities
CVE-2025-62525: OpenWrt vulnerable to local privilage escalation
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-22 · updated 2026-10-19
- Weakness: CWE-20
Description
OpenWrt Project is a Linux operating system targeting embedded devices. Prior to version 24.10.4, local users could read and write arbitrary kernel memory using the ioctls of the ltq-ptm driver which is used to drive the datapath of the DSL line. This only effects the lantiq target supporting xrx200, danube and amazon SoCs from Lantiq/Intel/MaxLinear with the DSL in PTM mode. The DSL driver for the VRX518 is not affected. ATM mode is also not affected. Most VDSL lines use PTM mode and most ADSL lines use ATM mode. OpenWrt is normally running as a single user system, but some services are sandboxed. This vulnerability could allow attackers to escape a ujail sandbox or other contains. This is fixed in OpenWrt 24.10.4. There are no workarounds.
Affected products
- openwrt: before 24.10.4 — fixed in 24.10.4
How to fix
Upgrade to a fixed version: openwrt 24.10.4. Check the vendor advisory for mitigations.
References
- https://github.com/openwrt/openwrt/commit/2a76abc5442e3f74d95b4caa9bb57e5488fc132e
- https://github.com/openwrt/openwrt/commit/e001b31163a77683ee741d169f794cfa50926f37
- https://github.com/openwrt/openwrt/security/advisories/GHSA-h427-frpr-7cqr
- https://openwrt.org/advisory/2025-10-22-2
Get alerted when CVE-2025-62525 or the next vulnerability affects your stack