What’s Vulnerable › Vulnerabilities
CVE-2025-62599: eprosima Fast DDS affected by Out-of-Memory in readPropertySeq via Manipulated DATA Submessage when DDS Security is enabled
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-03 · updated 2026-06-17
- Weakness: CWE-190
Description
eprosima Fast DDS is a C++ implementation of the DDS (Data Distribution Service) standard of the OMG (Object Management Group). Prior to 2.6.11, 2.14.6, 3.2.4, 3.3.1, and 3.4.1, when the security mode is enabled, modifying the DATA Submessage within an SPDP packet sent by a publisher causes an Out-Of-Memory (OOM) condition, resulting in remote termination of Fast-DDS. If the fields of PID_IDENTITY_TOKEN or PID_PERMISSION_TOKEN in the DATA Submessage — specifically by tampering with the length field in readPropertySeq — are modified, an integer overflow occurs, leading to an OOM during the resize operation. This vulnerability is fixed in 2.6.11, 2.14.6, 3.2.4, 3.3.1, and 3.4.1.
Affected products
- Debian Linux: 11.0, 12.0, 13.0
- eProsima Fast-DDS: before 2.6.11; from 3.0.0 before 3.3.1; 3.4.0 — fixed in 2.6.11, 3.3.1
How to fix
Upgrade to a fixed version: eProsima Fast-DDS 2.6.11, 3.3.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-62599 or the next vulnerability affects your stack