What’s Vulnerable › Vulnerabilities
CVE-2025-62615: AutoGPT has SSRF vulnerability in ReadRSSFeedBlock
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-02-04 · updated 2026-06-17
- Weakness: CWE-918
Description
AutoGPT is a platform that allows users to create, deploy, and manage continuous artificial intelligence agents that automate complex workflows. Prior to autogpt-platform-beta-v0.6.34, in RSSFeedBlock, the third-party library urllib.request.urlopen is used directly to access the URL, but the input URL is not filtered, which will cause SSRF vulnerability. This issue has been patched in autogpt-platform-beta-v0.6.34.
Affected products
- Significant-Gravitas AutoGPT: before 0.6.34 — fixed in 0.6.34
How to fix
Upgrade to a fixed version: Significant-Gravitas AutoGPT 0.6.34. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-62615 or the next vulnerability affects your stack