What’s Vulnerable › Vulnerabilities
CVE-2025-62659: The CookieConsent extension does not properly use reserved data attributes, thus introducing potential XSS vectors
- Severity: low (CVSS 2.1 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-22 · updated 2026-10-08
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in The Wikimedia Foundation MediaWiki CookieConsent extension allows Cross-Site Scripting (XSS).This issue affects MediaWiki CookieConsent extension: from v0.1.0 before v2.0.0.
Affected products
- The Wikimedia Foundation MediaWiki CookieConsent extension: from v0.1.0 before v2.0.0 — fixed in v2.0.0
How to fix
Upgrade to a fixed version: The Wikimedia Foundation MediaWiki CookieConsent extension v2.0.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-62659 or the next vulnerability affects your stack