What’s Vulnerable › Vulnerabilities
CVE-2025-62662: Stored XSS through system messages in AdvancedSearch
- Severity: medium (CVSS 6.9 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-18 · updated 2026-10-09
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in The Wikimedia Foundation Mediawiki - AdvancedSearch Extension allows Stored XSS.This issue affects Mediawiki - AdvancedSearch Extension: from master before 1.39.
Affected products
- The Wikimedia Foundation Mediawiki - AdvancedSearch Extension: from master before 1.39 — fixed in 1.39
How to fix
Upgrade to a fixed version: The Wikimedia Foundation Mediawiki - AdvancedSearch Extension 1.39. Check the vendor advisory for mitigations.
References
- https://gerrit.wikimedia.org/r/q/I91bba2b570643ef74e6c210e7250e05cd2aa388e
- https://phabricator.wikimedia.org/T402146
- https://phabricator.wikimedia.org/T402146
Get alerted when CVE-2025-62662 or the next vulnerability affects your stack