What’s Vulnerable › Vulnerabilities
CVE-2025-62697: Improperly sanitized style parameter in LanguageSelector
- Severity: high (CVSS 8.8 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-20 · updated 2026-10-08
- Weakness: CWE-74
Description
Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection') vulnerability in The Wikimedia Foundation Mediawiki - LanguageSelector Extension allows Code Injection.This issue affects Mediawiki - LanguageSelector Extension: from master before 1.39.
Affected products
- The Wikimedia Foundation Mediawiki - LanguageSelector Extension: from master before 1.39 — fixed in 1.39
How to fix
Upgrade to a fixed version: The Wikimedia Foundation Mediawiki - LanguageSelector Extension 1.39. Check the vendor advisory for mitigations.
References
- https://gerrit.wikimedia.org/r/q/I338288e756de4e58a3f1f02a9c205b37f4927935
- https://phabricator.wikimedia.org/T399724
Get alerted when CVE-2025-62697 or the next vulnerability affects your stack