What’s Vulnerable › Vulnerabilities
CVE-2025-62699: Special:Translate tool does not use the correct IP and User-Agent in the CheckUser tool
- Severity: medium (CVSS 6.9 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-21 · updated 2026-10-08
- Weakness: CWE-200
Description
Exposure of Sensitive Information to an Unauthorized Actor vulnerability in The Wikimedia Foundation Mediawiki - Translate Extension allows Footprinting. Translate extension appears to use jobs to make edits to translation pages. This causes the CheckUser tool to log the wrong IP and User-Agent making these edits un-auditable via the CheckUser tool.This issue affects Mediawiki - Translate Extension: from master before 1.39.
Affected products
- Wikimedia Foundation Mediawiki - Translate Extension: from master before 1.39 — fixed in 1.39
How to fix
Upgrade to a fixed version: Wikimedia Foundation Mediawiki - Translate Extension 1.39. Check the vendor advisory for mitigations.
References
- https://gerrit.wikimedia.org/r/q/I65c740c8ca5130b40463d687e2f0775951abbf22
- https://gerrit.wikimedia.org/r/q/Idac164418362c65d0ad37055fe9e0ad134197da3
- https://phabricator.wikimedia.org/T399627
Get alerted when CVE-2025-62699 or the next vulnerability affects your stack