What’s Vulnerable › Vulnerabilities
CVE-2025-62706: Authlib : JWE zip=DEF decompression bomb enables DoS
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-10-22 · updated 2026-10-19
- Weakness: CWE-400
Description
Authlib is a Python library which builds OAuth and OpenID Connect servers. Prior to version 1.6.5, Authlib’s JWE zip=DEF path performs unbounded DEFLATE decompression. A very small ciphertext can expand into tens or hundreds of megabytes on decrypt, allowing an attacker who can supply decryptable tokens to exhaust memory and CPU and cause denial of service. This issue has been patched in version 1.6.5. Workarounds for this issue involve rejecting or stripping zip=DEF for inbound JWEs at the application boundary, forking and add a bounded decompression guard via decompressobj().decompress(data, MAX_SIZE)) and returning an error when output exceeds a safe limit, or enforcing strict maximum token sizes and fail fast on oversized inputs; combine with rate limiting.
Affected products
- authlib: before 1.6.5 — fixed in 1.6.5
How to fix
Upgrade to a fixed version: authlib 1.6.5. Check the vendor advisory for mitigations.
References
- https://github.com/authlib/authlib/commit/e0863d5129316b1790eee5f14cece32a03b8184d
- https://github.com/authlib/authlib/security/advisories/GHSA-g7f3-828f-7h7m
- https://lists.debian.org/debian-lts-announce/2025/10/msg00032.html
Get alerted when CVE-2025-62706 or the next vulnerability affects your stack