What’s Vulnerable › Vulnerabilities
CVE-2025-62783: InventoryGui affected by item duplication in GUIs which use GuiStorageElement
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-27 · updated 2026-10-08
- Weakness: CWE-837
Description
InventoryGui is a library for creating chest GUIs for Bukkit/Spigot plugins. Versions 1.6.1-SNAPSHOT and earlier contain a vulnerability where any plugin using the `GuiStorageElement can allow item duplication when the experimental Bundle item feature is enabled on the server. The vulnerability is resolved in version 1.6.2-SNAPSHOT.
Affected products
- Phoenix616 InventoryGui: before 1.6.2 — fixed in 1.6.2
How to fix
Upgrade to a fixed version: Phoenix616 InventoryGui 1.6.2. Check the vendor advisory for mitigations.
References
- https://github.com/Phoenix616/InventoryGui/commit/27a52ef6d934a1c232e110e0010e4aa810c27029
- https://github.com/Phoenix616/InventoryGui/issues/48
- https://github.com/Phoenix616/InventoryGui/security/advisories/GHSA-598q-jw82-5w66
Get alerted when CVE-2025-62783 or the next vulnerability affects your stack