What’s Vulnerable › Vulnerabilities
CVE-2025-62784: InventoryGui allows item duplication in GUIs which use GuiStorageElement
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-27 · updated 2026-10-08
- Weakness: CWE-837
Description
InventoryGui is a library for creating chest GUIs for Bukkit/Spigot plugins. Versions before 1.6.5 contain a vulnerability where any plugin using a GUI with the GuiStorageElement and allows taking out items out of that element can allow item duplication when the experimental Bundle item feature is enabled on the server. The vulnerability is resolved in version 1.6.5.
Affected products
- Phoenix616 InventoryGui: before 1.6.5 — fixed in 1.6.5
How to fix
Upgrade to a fixed version: Phoenix616 InventoryGui 1.6.5. Check the vendor advisory for mitigations.
References
- https://github.com/Phoenix616/InventoryGui/commit/690fc91d137c6cc04f6ed3a89449050964dd8cb9
- https://github.com/Phoenix616/InventoryGui/security/advisories/GHSA-7whh-79j3-7c55
Get alerted when CVE-2025-62784 or the next vulnerability affects your stack