What’s Vulnerable › Vulnerabilities
CVE-2025-62795: JumpServer Unauthorized LDAP Configuration Access via WebSocket
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-10-30 · updated 2026-10-19
- Weakness: CWE-863
Description
JumpServer is an open source bastion host and an operation and maintenance security audit system. Prior to v3.10.21-lts and v4.10.12-lts, a low-privileged authenticated user can invoke LDAP configuration tests and start LDAP synchronization by sending crafted messages to the /ws/ldap/ WebSocket endpoint, bypassing authorization checks and potentially exposing LDAP credentials or causing unintended sync operations. This vulnerability is fixed in v3.10.21-lts and v4.10.12-lts.
Affected products
- jumpserver: before 3.10.21; from 4.0.0 before 4.10.12 — fixed in 3.10.21, 4.10.12
How to fix
Upgrade to a fixed version: jumpserver 3.10.21, 4.10.12. Check the vendor advisory for mitigations.
References
- https://github.com/jumpserver/jumpserver/security/advisories/GHSA-7893-256g-m822
- https://github.com/jumpserver/jumpserver/security/advisories/GHSA-7893-256g-m822
Get alerted when CVE-2025-62795 or the next vulnerability affects your stack