What’s Vulnerable › Vulnerabilities
CVE-2025-62800: FastMCP vulnerable to reflected XSS in client's callback page
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-10-28 · updated 2026-10-08
- Weakness: CWE-79
Description
FastMCP is the standard framework for building MCP applications. Versions prior to 2.13.0 have a reflected cross-site scripting vulnerability in the OAuth client callback page (oauth_callback.py) where unescaped user-controlled values are inserted into the generated HTML, allowing arbitrary JavaScript execution in the callback server origin. The issue is fixed in version 2.13.0.
Affected products
- jlowin fastmcp: before 2.13.0 — fixed in 2.13.0
How to fix
Upgrade to a fixed version: jlowin fastmcp 2.13.0. Check the vendor advisory for mitigations.
References
- https://github.com/jlowin/fastmcp/security/advisories/GHSA-mxxr-jv3v-6pgc
- https://github.com/jlowin/fastmcp/security/advisories/GHSA-mxxr-jv3v-6pgc
Get alerted when CVE-2025-62800 or the next vulnerability affects your stack