What’s Vulnerable › Vulnerabilities
CVE-2025-62801: FastMCP vulnerable to windows command injection in FastMCP Cursor installer via server_name
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-10-28 · updated 2026-10-08
- Weakness: CWE-78
Description
FastMCP is the standard framework for building MCP applications. Versions prior to 2.13.0, a command-injection vulnerability lets any attacker who can influence the server_name field of an MCP execute arbitrary OS commands on Windows hosts that run fastmcp install cursor. This vulnerability is fixed in 2.13.0.
Affected products
- jlowin fastmcp: before 2.13.0 — fixed in 2.13.0
How to fix
Upgrade to a fixed version: jlowin fastmcp 2.13.0. Check the vendor advisory for mitigations.
References
- https://github.com/jlowin/fastmcp/security/advisories/GHSA-rj5c-58rq-j5g5
- https://github.com/jlowin/fastmcp/security/advisories/GHSA-rj5c-58rq-j5g5
Get alerted when CVE-2025-62801 or the next vulnerability affects your stack