What’s Vulnerable › Vulnerabilities
CVE-2025-63238
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-04-09 · updated 2026-10-15
- Weakness: CWE-79
Description
A Reflected Cross-Site Scripting (XSS) affects LimeSurvey versions prior to 6.15.11+250909, due to the lack of validation of gid parameter in getInstance() function in application/models/QuestionCreate.php. This allows an attacker to craft a malicious URL and compromise the logged in user.
Affected products
- LimeSurvey: before 6.15.12 — fixed in 6.15.12
How to fix
Upgrade to a fixed version: LimeSurvey 6.15.12. Check the vendor advisory for mitigations.
References
- https://gist.github.com/masquerad3r/f913ab479e8de2ad71987ef98a088fb5
- https://github.com/LimeSurvey/LimeSurvey/commit/80769a677dc82ddb1fcced4af19bd959d583208d
Get alerted when CVE-2025-63238 or the next vulnerability affects your stack