What’s Vulnerable › Vulnerabilities
CVE-2025-6338: Possible denial of service with multiple incoming connections to a Schannel based server with a TLS backend
- Severity: critical (CVSS 9.2 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-16 · updated 2026-10-09
- Weakness: CWE-459
Description
There is an incomplete cleanup vulnerability in Qt Network's Schannel support on Windows which can lead to a Denial of Service over a long period. This issue affects Qt from 5.15.0 through 6.8.3, from 6.9.0 before 6.9.2.
Affected products
- Qt: from 5.15.0 through 6.8.3; from 6.9.0 before 6.9.2 — fixed in 6.9.2
How to fix
Upgrade to a fixed version: Qt 6.9.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-6338 or the next vulnerability affects your stack