What’s Vulnerable › Vulnerabilities
CVE-2025-6350: WP VR – 360 Panorama and Free Virtual Tour Builder For WordPress <= 8.5.32 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-28 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP VR – 360 Panorama and Free Virtual Tour Builder For WordPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘hotspot-hover’ parameter in all versions up to, and including, 8.5.32 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- RexTheme WP VR: before 8.5.33 — fixed in 8.5.33
How to fix
Upgrade to a fixed version: RexTheme WP VR 8.5.33. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/wpvr/trunk/admin/classes/class-wpvr-ajax.php#L171
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=3317520%40wpvr%2Ftrunk&old=3314284%40wpvr%2Ftrunk&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/ce3d82ec-5f94-4511-a6ba-8ee1dec06160?source=cve
Get alerted when CVE-2025-6350 or the next vulnerability affects your stack