What’s Vulnerable › Vulnerabilities
CVE-2025-6375: poco MultipartReader.cpp MultipartInputStream null pointer dereference
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-06-21 · updated 2026-06-17
- Weakness: CWE-404
Description
A vulnerability was found in poco up to 1.14.1. It has been rated as problematic. Affected by this issue is the function MultipartInputStream of the file Net/src/MultipartReader.cpp. The manipulation leads to null pointer dereference. The attack needs to be approached locally. The exploit has been disclosed to the public and may be used. Upgrading to version 1.14.2 is able to address this issue. The patch is identified as 6f2f85913c191ab9ddfb8fae781f5d66afccf3bf. It is recommended to upgrade the affected component.
Affected products
- poco: before 1.14.2 — fixed in 1.14.2
How to fix
Upgrade to a fixed version: poco 1.14.2. Check the vendor advisory for mitigations.
References
- https://github.com/pocoproject/poco/commit/6f2f85913c191ab9ddfb8fae781f5d66afccf3bf
- https://github.com/pocoproject/poco/issues/4915
- https://github.com/pocoproject/poco/releases/tag/poco-1.14.2-release
- https://github.com/user-attachments/files/19524599/poco_crash.txt
- https://vuldb.com/?ctiid.313370
- https://vuldb.com/?id.313370
- https://vuldb.com/?submit.597446
- https://github.com/pocoproject/poco/issues/4915
Get alerted when CVE-2025-6375 or the next vulnerability affects your stack