What’s Vulnerable › Vulnerabilities
CVE-2025-63918
- Severity: medium (CVSS 6.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-11-17 · updated 2026-06-17
- Weakness: CWE-22
Description
PDFPatcher executable does not validate user-supplied file paths, allowing directory traversal attacks allowing attackers to upload arbitrary files to arbitrary locations.
Affected products
- Cnblogs Pdfpatcher: before 1.1.3.4663 — fixed in 1.1.3.4663
How to fix
Upgrade to a fixed version: Cnblogs Pdfpatcher 1.1.3.4663. Check the vendor advisory for mitigations.
References
- https://github.com/cydtseng/Vulnerability-Research/blob/main/pdfpatcher/DirectoryTraversal-ImageExport.md
- https://github.com/wmjordan/PDFPatcher
- https://www.cnblogs.com/pdfpatcher
Get alerted when CVE-2025-63918 or the next vulnerability affects your stack