What’s Vulnerable › Vulnerabilities
CVE-2025-64094: DNN vulnerable to stored cross-site-scripting (XSS) via SVG upload
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-28 · updated 2026-10-08
- Weakness: CWE-79
Description
DNN (formerly DotNetNuke) is an open-source web content management platform (CMS) in the Microsoft ecosystem. Prior to 10.1.1, sanitization of the content of uploaded SVG files was not covering all possible XSS scenarios. This vulnerability exists because of an incomplete fix for CVE-2025-48378. This vulnerability is fixed in 10.1.1.
Affected products
- DotNetNuke CMS Fixed in 9.1.1: before 10.1.1 — fixed in 10.1.1
How to fix
Upgrade to a fixed version: DotNetNuke CMS Fixed in 9.1.1 10.1.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-64094 or the next vulnerability affects your stack