What’s Vulnerable › Vulnerabilities
CVE-2025-64097: NervesHub has Insufficient Token Entropy that Allows Authentication Bypass via Brute Force
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-22 · updated 2026-06-17
- Weakness: CWE-330
Description
NervesHub is a web service that allows users to manage over-the-air (OTA) firmware updates of devices in the field. A vulnerability present starting in version 1.0.0 and prior to version 2.3.0 allowed attackers to brute-force user API tokens due to the predictable format of previously issued tokens. Tokens included user-identifiable components and were not cryptographically secure, making them susceptible to guessing or enumeration. The vulnerability could have allowed unauthorized access to user accounts or API actions protected by these tokens. A fix is available in version 2.3.0 of NervesHub. This version introduces strong, cryptographically-random tokens using `:crypto.strong_rand_bytes/1`, hashing of tokens before database storage to prevent misuse even if the database is compromised, and context-aware token storage to distinguish between session and API tokens. There are no practical workarounds for this issue other than upgrading. In sensitive environments, as a temporary mitigation, firewalling access to the NervesHub server can help limit exposure until an upgrade is possible.
Affected products
- nerves-hub nerves_hub_web: from 1.0.0 before 2.3.0 — fixed in 2.3.0
How to fix
Upgrade to a fixed version: nerves-hub nerves_hub_web 2.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/nerves-hub/nerves_hub_web/pull/2024
- https://github.com/nerves-hub/nerves_hub_web/releases/tag/v2.3.0
- https://github.com/nerves-hub/nerves_hub_web/security/advisories/GHSA-m9vj-776q-vc8m
Get alerted when CVE-2025-64097 or the next vulnerability affects your stack