What’s Vulnerable › Vulnerabilities
CVE-2025-64106: Cursor: Speedbump Modal Bypass in MCP Server Deep-Link
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-04 · updated 2026-10-19
- Weakness: CWE-78
Description
Cursor is a code editor built for programming with AI. In versions 1.7.28 and below, an input validation flaw in Cursor's MCP server installation enables specially crafted deep-links to bypass the standard security warnings and conceal executed commands from users if they choose to accept the server. If an attacker is able to convince a victim to navigate to a malicious deeplink, the victim will not see the correct speedbump modal, and if they choose to accept, will execute commands specified by the attackers deeplink.
Affected products
- cursor: before 2.0 — fixed in 2.0
How to fix
Upgrade to a fixed version: cursor 2.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-64106 or the next vulnerability affects your stack