What’s Vulnerable › Vulnerabilities
CVE-2025-64107: Cursor is Vulnerable to Path Manipulation Using Backslashes on Windows
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-04 · updated 2026-10-19
- Weakness: CWE-22
Description
Cursor is a code editor built for programming with AI. In versions 1.7.52 and below, manipulating internal settings may lead to RCE. Cursor detects path manipulation via forward slashes (./.cursor/./././././mcp.json etc.), and requires human approval to complete the operation. However, the same kind of manipulation using backslashes was not correctly detected, allowing an attacker who had already achieved prompt injection or some other level of control to overwrite sensitive editor files without approval on Windows machines. This issue is fixed in version 2.0.
Affected products
- cursor: before 2.0 — fixed in 2.0
How to fix
Upgrade to a fixed version: cursor 2.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-64107 or the next vulnerability affects your stack