What’s Vulnerable › Vulnerabilities
CVE-2025-64108: Cursor's Sensitive File Modification can Lead to NTFS Path Quirks
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-04 · updated 2026-10-19
- Weakness: CWE-22
Description
Cursor is a code editor built for programming with AI. In versions 1.7.44 and below, various NTFS path quirks allow a prompt injection attacker to circumvent sensitive file protections and overwrite files which Cursor requires human approval to overwrite. Modification of some of the protected files can lead to RCE. Must be chained with a prompt injection or malicious model attach. Only affects systems supporting NTFS. This issue is fixed in version 2.0.
Affected products
- cursor: before 2.0 — fixed in 2.0
How to fix
Upgrade to a fixed version: cursor 2.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-64108 or the next vulnerability affects your stack